Welcome to street holdens enjoy your stay

Latest topics

» Suey's vu Ss
by suey Sat Jul 14, 2012 12:44 pm

» Gday new guy from tassie
by VRCALAIS Sat Jul 14, 2012 10:10 am

» my 1996 VS Acclaim
by MICK JE76VS Mon May 14, 2012 1:01 pm

» vq caproce shell
by VRCALAIS Fri Apr 27, 2012 4:06 pm

» Whats your JOB
by O.SODVS Fri Apr 27, 2012 12:37 pm

» Diagnostic and Tuning Software
by O.SODVS Thu Apr 26, 2012 11:48 am

» OSODVS - VN SS
by O.SODVS Wed Apr 25, 2012 3:19 pm

» The NEW VL SL
by O.SODVS Wed Apr 25, 2012 2:41 pm

» where is every one????
by O.SODVS Wed Apr 25, 2012 2:01 pm


You are not connected. Please login or register

VL Commodore RB30 Troubleshooting + Maintenance

View previous topic View next topic Go down  Message [Page 1 of 1]

Detox_nath83

avatar
SUPER MODERATOR
RB30 Engine Troubleshooting/Maintenance Step by step
Helpful common probs on vls, To Help New Comers on Vl Commodores

credit gose to VL_RACER of Street Commodores for this write up.


1. Air flow meter: check the connections including rubber boot, clean with contact cleaner if necessary. remove the airflow meter (undo the clamp behind it and remove the top of the airbox and air flow meter together) and clean using contact cleaner or some other cleaner thats safe on electrical components. clean out the airbox and replace the air filter if necessary ($10 for a cheap one, $100 for K&N) reinstall everything

if the car is stalling after starting or seems to be choking still after this, check AAC valve, air regulator, make sure there's no air leaks, then replace the air flow meter ($20-$60 from wreckers, approx $150 reconditioned, about $400-$600 new)

TO CHECK AND ADJUST MIXTURE:
1. start and run the engine until its at operating temperature
2. set idle speed and timing to specified values
3. take off the passenger kick panel to view the LED's on the ECU
4. start and run the motor at 2000rpm for 2 mins
5. check the flashes from the LED's on the ecu while at 2000rpm, they should both flash together more than 5 times every 10 seconds. if they don't you have ecu or oxygen sensor issues (refer to the picture at the bottom explaining the interpretation of flashes other than what are stated)
6. if there are more than 5 flashes per 10 secs, stop the engine, disconnect the wiring connector from the AAC valve and the throttle switch
7. start and run the engine at 2000rpm for 2 mins
8. let the engine idle
9. the leds should now flash simultaneously
10. if the green light is flashing more the mixture is lean, if the red is flashing more the mixture is richer than it should be.
10. if the LED's do not flash together remove the plug next to the Air flow meter connector and adjust the screw until they flash together (clockwise raises the resistance and leans the mixture, anti clockwise lowers the resistance and richens the mixture)
11. replace the plug, replace the AAC and throttle switch connectors and return to instruction 4. do the test again to check that the mixture is now right
12. if the mixture cannot be adjusted so that the leds flash together, its time to test the AFM

TO TEST AFM:
pull back the rubber boot on the AFM connector revealing the wires. grab your multimeter and stick the probes on wire 4 (white) and 2 (1 being the closest to the airbox) with the multimeter on DC voltage. turn the ignition on and the voltage reading should be between 1.26V (lean) and 1.32V (rich). this is the base setting and if it is out then the AFM wont be able to be adjusted to a satisfactory mixture (meaning you need a new one)

and just for interests sake you can test the mixture by putting the probes on wire 1 and 3 with the key on and measuring the voltage. 3.6V is the factory setting which is lean, with 2.0V being rich. the mixture should be in the vacinity of 2.0-4.0i couldn't get the LED's to flash and therefore couldn't set it using the computer so i did it this way and set it to 3.5V (AFM resistance of 375 ohms) and then checked it using the computer and it was right, LED's flashing together.


2. Throttle body: undo the bolt attaching the intake piping to the throttle cable bracket. undo the pcv valve hose. undo the clamp holding the intake to the throttle body. undo the clamp holding the piping to the air flow meter. clean the throttle body with throttle body cleaner making sure you get all of the black crap out. reinstall intake and clamps and start.

this will improve throttle response and a tendency to stutter a bit when the accelerator is pressed suddenly


3. AAC Valve: undo the connector and 2 screws holding it to the plenum chamber. clean the black carbon off the valve with throttle body cleaner. check that the valve has plenty of movement and won't be prone to sticking, this will raise the idle by allowing too much air to bypass the throttle body or stop the flow all together depending where it is stuck. if it is a bit sticky put a little wd40 to make it slide easier. reinstall the valve.


4. Air regulator: undo the connector and the hose clamps above and below the valve. remove and clean with throttle body cleaner. reinstall

this will correct warm up running issues and influences the air flow meter so should be done before replacing the air flow meter


5. Coolant Temperature sensor : check connector and clean if necessary. make sure the earth to the right of the connector is secure.

this corrects a temp guage that isn't working and a engine that is running rich and using heaps of fuel. if its still running rich it may be the oxygen sensor (approx $200 i think)


6: Distributor: remove the 2 screws and check the cap and rotor for wear, corrosion and tracking. a pitted rotor connection will need replacing ($10). replace the cap if necessary ($25) also check plugs (starting at $20 a set) and replace if neccessary


7. Fuel filter: start the engine, remove the fuel pump fuse (#3 i think) and wait for the engine to stall. run the starter to release fuel pressure. put the fuse back in. working under the rear axle remove the clamps and hoses and replace the filter (make sure the flow arrow is the right way).

this will improve power and smoothness.


8. Crank Angle Sensor Boot: my boot had fallen to bits allowing water in and causing major corrosion of the terminals and wires and dodgey running one day when it got a bit wet. i've also found that it was the cause of a afm fault code being displayed one day when i ran a diagnostic (its on the same circuit as the afm). a boot and connector kit can be bought for about $15 from repco to fix this problem


9. Timing: the timing on our vl was 22 degrees btdc when we bought it, meaning it would ping its tits off on regular unleaded but run great on premium. i got it brought back to 17 degrees (15 is standard) and continued to use premium but it then started to run like crap when it was cold (coughing and spluttering on take off until the temp went up). its now on 20 degrees (still with premium) and runs a lot better.

standard vl's should run 15 degrees on regular unleaded or up to 20 on premium. going over 20 isn't advised because of pinging issues even on premium but then again i'm yet to talk to a mechanic who doesn't think i'm nuts for going up above standard at all.

TO ADJUST: get yourself a timing light (or borrow one). make sure you get a xenon one cos neon ones aren't worth shit. xenon ones are about $60 from supercheap and about $100 from repco. hook it up (read the instructions that come with it), start the motor and undo the 12mm bolt next to the dizzy. counting the timing marks from left to right on the crankshaft pulley where the first is 0 and the last is 30, move the distributor until you get the setting you want. tighten the bolt and check that the setting is still right. its a good idea to make a mark on the dizzy bolt slider where 15 and 20 degrees are so then you can adjust it yourself between those without having to need a timing light again. check and adjust the mixture after this for optimum results


10. Radiator/Cooling System: The radiator and cooling system should be flushed every 40,000k's or 2 years and thermostats changed every 2-3 years as well. before you start you should check everywhere for leaks so that you can go and get parts you need before dumping the coolant. common places to look are top and bottom hose housings, hoses, water pump, heater hoses, welch plugs etc. i got the following parts to ensure mine is in good working order:

- top radiator hose
- bottom radiator hose
- top housing
- thermostat housing
- thermostat
- radiator cap
- silicone sealant
- tectaloy ultra cool gold (make sure you get coolant suitable for alloy heads)
- demineralised water
- hose clamps
- hose from filler neck to expansion tank

i'm being very thorough here so all that is absolutely necessary is the coolant and water. now to drop the coolant:

1. put the heater to the hot position
2. remove the bottom radiator hose and radiator cap and drain the coolant into a drain tin
3. remove the cylinder block drain plug (its the lower of the 2 plugs under the exhaust manifold towards the back of the engine). you may need to put some wd40 on this the day before to loosen it up cos they are sticky little buggers
4. once drained remove all hoses from the radiator, remove the shroud screws and clips on the front plastic piece
5. lift the shroud up slightly out of the bottom clips and push back over the fan
6. get some pliers on the radiator clips and remove them, slide out the radiator
7. block the inlet and reverse flush through the outlet until the water flowing from the filler neck is clean
8. stand up the radiator and spray it rear to front to wash out any dirt, bugs etc in it
9. reinstall the radiator
10. if replacing the thermostat remove the lower hose and thermostat housing (it'll be stuck so lever it out)
11. pull the thermostat out and clean all around the mounting faces
12. put the new thermostat in with the jiggle valve to the top and the gasket and silicone sealer
13. intall the cover and do the bolts up to 29NM (same tightness as plugs)
14. while waiting for the sealer to set replace the top hose housing, it should come with a gasket
15. once the sealer has hardened reinstall all hoses and clamps
16. fill the radiator and replace the cap
TO BLEED: (vl's need to be bled because the highest water jacket is above the highest part of the radiator)
18. undo the bleed bolt near the coolant temp sensor
17. remove the hose going from the filler neck to the expansion tank at the expansion tank end, hold it higher than the bolt hole and using a small funnel, fill until coolant runs out of the bleed bolt hole
18. reinstall the bolt
19. remove the bleed bolt on the plenum
20. fill till coolant comes out as above
21. reinstall the bleed bolt and hose and fill the expansion tank to an inch over maximum
22. start and run the engine until its at operating temperature. check for leaks
23. once cooled the level in the expansion tank should be on the maximum mark


doing this will make it run cooler obviously and prevent corrosion. if the system isn't bled properly the air trapped inside will create hotspots and blow the headgasket. its very important this is done right and re done on occaision just to be safe. i do mine every few weeks. another thing to note is aftermarket thermostats run hotter than genuine ones. our temp guage used to sit on 1-2 bars (genuine thermostat) now it sits just under half and warms up a lot quicker (dayco thermostat) we'll see how it goes i may put a genuine one back in cos i only found this out after actually doing it

11. Injectors: Run some injector cleaner through a tank of fuel and check the electrical connections on top of the injectors. using contact and circuit board cleaner spray the plug and the terminals on the injector, these are prone to corrosion. you'll have to take the intake pipe off the throttle body for easier access to the connections. check the fuel hose clamps on each injector too where it meets the rail, i had a loose one that appeared to be leaking a little. clean it all up and plug the connections back in

after doing this it appeared to be a bit smoother and there was a bit of a intermittant miss that seems to have disappeared. good to check anyway if you are having some running issues

12. Oil: to change warm the engine (not too hot) and turn it off. undo the oil cap and undo the sump plug. let it drain then unscrew the filter and remove. replace the sump plug and smear some oil around the rubber o-ring on the new filter. screw the new filter on tight. refill with 20W/50 oil, 4.7L for filter change and 4.3L if not changing the filter. put some lifter free (nulon or similar) in the oil if the lifters are ticking or just for general maintanence to stop it happening. replace the oil cap, run until warm then turn off, let it settle and check the oil level. i do ours every 5000k's and filter every 10000, keeps the lifters from building up sludge and ticking if you do it often.

13. Ignition Leads: to check the resistance of the leads get a multimeter and set it to the 20K scale resistance. unplug each lead (one at a time makes it easier to remember where they went) and measure the resistance from one terminal of the lead to the other. the gregory's manual states that no lead should exceed 24000 ohms or it needs replacing. also check that the lead isn't cracked or splitting and that the terminals on each end aren't damaged. if one lead is faulty its a good idea to replace them as a set, however they are sold singularly if you just want one.

If you want something with lower resistance than standard, silicone ignition leads such as top gun are around 7000 ohms per metre and the spiral wound conductor leads have resistances as low as under 1000 ohms per metre (such as Top Gun MAX300).

14. Engine Control Unit
TO CHECK ERROR CODES:
1. remove screw retaining the passenger side kick panel
2. turn the diagnostic mode selector fully clockwise to diagnostic
3. start the engine and let it idle
4. watch the LED's flash (red and green), the red represents tens and the green represents ones (so if the red flashes twice and the green 4 times, thats 24). 14, 23, 24, and 31 should show
5. drive the car above 10km/h, this will cancel code 14
6. stop the motor and then turn the ignition to the on position
7. press the accelerator, this will cancel 23
8. put the car in neutral, then back into another gear, then back to neutral. this will cancel 24
9. turn the air con on, then off this will cancel 31
10. look at the codes that are now displayed, 31 means you dont have air con or its not working and 44 means your air con is working.
11. any other codes displayed besides this means there is a fault in that section
12. turn the diagnostic mode selector back full anticlockwise then turn the ignition off.
13. erase the memory by turning the ignition on, then moving the diagnostic mode selector fully clockwise for 2 seconds, then fully anticlockwise for 2 seconds. turn the key off and the memory is now cleared

CODES ARE:
11 Crank angle sensor circuit
12 Air flow meter circuit
13 coolant temperature sensor circuit
14 Vehicle speed sensor circuit
21 ignition signal circuit
23 throttle switch circuit
24 neutral switch circuit
31 satisfactory operation (non air conditioned models) air conditioner circuit (air conditioned models)
32 starter signal circuit
34 detonation sensor circuit (turbo models)
44 satisfactory operation (air conditioned models)


_________________
>>>-------My Ride-------<<<

Injection is Nice, But id Rather be Blown!

View user profile

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum